ADT version problems in Android: Java. Lang. noclassdeffounderror and conversion to Dalvik format failed with error 1 error

Source: Internet
Author: User

 I recently encountered more than N errors when I configured the android Development Environment on Ubuntu. Let's talk about it. If there is a similar error, just modify it. So far, the ADT version has been upgraded to 18. When the SDK version is upgraded to 4.0.3, the ADT version is required to be 17 or later. If any problem occurs after the upgrade, it may be caused by the JDK version. Please note that, adt17 requires that the JDK version be in JDK 1.6 or later.

When the ADT version is 17 or later, if a third-party jar package is referenced in the project, the Java. Lang. noclassdeffounderror error may occur and the referenced classes in the jar package cannot be found. How to modify it? In eclipse, the referenced third-party jar packages are all placed under lib and changed lib to libs. Someone may ask, if there is no lib folder, create a new libs folder, put the third-party class library in this folder, and an error will be reported at this time. You need to build the path again,

Under cleanCode.

IfArticleNot satisfied. It is recommended that you search for keywords:

Android ADT java. Lang. noclassdeffounderror

Instead of Java. Lang. noclassdeffounderror

Because the latter searches for most of the content about j2se and J2EE problems.

Continue compilation this morning and find the conversion to Dalvik format failed with error 1 error. If this problem occurs, first clean it. If it is not solved, open configure build path of build path, for example, check whether there are repeated jar packages. If yes, delete the repeated packages. You can.

If you have any questions, please leave a message.

Sometimes there may be conflicts between the imported package and the android package, and no error is reported on the project. However, the conversion to Dalvik format failed with error 1 error is reported during running, which is rare. If this error occurs, the above method cannot be solved. try to create a new project without writing code, import the package, run the check to check whether an error is returned, such as an error, delete one of the packages, and then run the check, in this way, the conflicting package may be found.

Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.