Solution to the Cannot send session cache limiter problem in php

Source: Internet
Author: User

When I was using php sessions today, I encountered a problem that could not be solved before. The following prompt appears on the page:

Warning: session_start () [function. session-start]: Cannot send session cache limiter-headers already sent (output started at E: \ php \ code \ admin. php: 1) in E: \ php \ code \ logolist \ adminlogo. php on line 2

I searched the internet and some people said that it was because there were other html code before the session_start (); statement, but my session_start (); was already in the front.
Another reason is that the session save path is not set. You need to modify the session. save_path = "C:/phpsession" in php. ini [the path behind the php. ini file is set by yourself, and the path must exist. The php. ini file should generally be located under the System Disk/Windows Directory]

However, this prompt is displayed after I make the above settings. After repeated tests, the problem was finally solved.
Solution:
Modify session. auto_start = 0 in php. ini to session. auto_start = 1.

Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.