Problems encountered when installing PHP on debian

Source: Internet
Author: User
Tags openssl version
The following error occurs during the configuration of PHP installation on debian: running ing & nbsp; extensionschecking & nbsp; for & nbsp; OpenSSL & nbsp; support... & nbsp; problems encountered by yescheckin when installing PHP on debian
The following error occurs during configuration:
Grouping extensions
Checking for OpenSSL support... yes
Checking for Kerberos support... no
Checking for pkg-config.../usr/bin/pkg-config
Checking for OpenSSL version...> = 0.9.6
Checking for CRYPTO_free in-lcrypto... yes
Checking for SSL_CTX_set_ssl_version in-lssl... yes
Checking for PCRE support... yes
Checking for ZLIB support... yes
Checking if the location of ZLIB install directory is defined... no
Checking for gzgets in-lz... yes
Checking whether to enable bc style precision math functions... no
Checking for BZip2 support... no
Checking whether to enable calendar conversion support... no
Checking for cpdflib support... no
Checking for CRACKlib support... no
Checking whether to enable ctype functions... yes
Checking for CURL support... yes
Checking for CURL in default path... not found
Configure: error: Please reinstall the libcurl distribution-
Easy. h shoshould be in /Include/curl/

Then I found a solution on the Internet:
# Apt-get install curl
# Apt-get install libcurl3
# Apt-get install libcurl4-gnutls-dev

But an error occurred while running the apt-get install libcurl4-gnutls-dev:
# Apt-get install libcurl4-gnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages cocould not be installed. This may mean that you have
Requested an impossible situation or if you are using the unstable
Distribution that some required packages have not yet been created
Or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
Libcurl4-gnutls-dev: Depends: libcurl3-gnutls (= 7.18.2-8lenny4) but 7.19.5-1.1 is to be installed
Depends: libgnutls-dev but it is not going to be installed
Depends: libidn11-dev but it is not going to be installed
Depends: libkrb5-dev but it is not going to be installed or
Hurd but it is not installable
Depends: libldap2-dev but it is not going to be installed
Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.