Dm365 + ec122 debugging (2)

Source: Internet
Author: User
Tags time 0

Hardware Platform: ritai dm365 Development Board

Development Board kernel: Linux 2.6.18

Dvsdk version: 2_10_00_17


Question 2:

Cannot open/dev/ttyusb0: device or resource busy

Cannot open/dev/ttyusb1: device or resource busy

Cannot open/dev/ttyusb2: device or resource busy


**** ************************************

Following the previous article dm365 + ec122 debugging (1), this article continues to debug ec122 on the dm365 board. Now the Development Board is loaded with the file system on nandflash.

Step 1: Run usb_modeswitch-W

Target device description data
Manufacturer: Huawei Technologies
Product: Huawei mobile
Serial No .:
Found correct target Device

Mode switch succeeded. Bye.

Oh, shit! The above information has not caused OOM killer. So reboot again, usb_modeswitch-W, still does not cause OOM killer. Great. It seems that the 3G module can be adjusted immediately. In the/dev/TTS/directory, four nodes, USB 0, usb1, usb2, and usb3, are added.

Well, try wvdial. So run wvdialconf/etc/wvdial. conf. The new problem is "problem 2 ". Oh, my God. Don't torture me like this, okay? I really want to write my paper!

After persistently searching for solutions on the Internet, we finally see the title 《[Solved] HSDPA Huawei e220 and wvdial: device or resource busy. At this point, I am delighted to see the [solved! Reference the key content:

**** ************************************

Hey, I just recently went through this and it nearly drove me nuts, had the 'device busy' problem even for root. after expiration, Expiration days and several aneurysms I finally found my problem, maybe this will help you too.

It turned out that wvdial tries to create a lock file for the USB device in '/var/lock ', but for some reason when I looked in '/var' I had no 'lock' directory. I checked my other arch machine and it has A'/var/lock' directory, so I'm not sure where this
One disappeared.

Soon as I created '/var/lock' wvdial worked perfectly. Hope this helps you out.


Last edited by wittfella (15:45:48)

---- From

Https:// Id = 74163

**** ************************************

Hurry up and check your file system. Oh, we did not find '/var/lock'. Create it decisively. In addition, the four symbolic links of ttyusb0 ttyusb1 ttyusb2 ttyusb3 are manually created under the/dev directory, respectively for usb0 usb1 usb2 usb3 under the/dev/TTS/directory. Run wvdialconf/etc/wvdial. conf again and find ttyusb0 correctly. Then run wvdial.
, Everything is OK, dial successful!


**** ************************************

--> Wvdial: Internet dialer version 1.61
--> Warning: Section [dialer [08] conf] does not exist in wvdial. conf.
--> Warning: Section [dialer/etc/wvdial. conf] does not exist in wvdial. conf.
--> Cannot get information for serial port.
--> Initializing MODEM.
--> Sending: atz
--> Sending: atq0 V1 E1 S0 = 0 & C1 & D2 + fclass = 0
Atq0 V1 E1 S0 = 0 & C1 & D2 + fclass = 0
--> Modem initialized.
--> Sending: atdt #777
--> Waiting for carrier.
Atdt #1, 777
Connect 3100000
--> Carrier detected. Starting PPP immediately.
--> Starting pppd at THU Jan 1 00:17:15 1970
--> PID of pppd: 833
--> Using interface ppp0
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Local IP address
--> Pppd: [08] X [03]
--> Remote IP address
--> Pppd: [08] X [03]
--> Primary DNS address
--> Pppd: [08] X [03]
--> Secondary DNS address
--> Pppd: [08] X [03]
Caught Signal 2: attempting to exit gracefully...
--> Terminating on signal 15
--> Pppd: [08] X [03]
--> Connect time 0.5 minutes.
--> Pppd: [08] X [03]
--> Pppd: [08] X [03]
--> Disconnecting at THU Jan 1 00:17:45 1970

**** ************************************

The painful debugging process finally had some satisfactory results.

Okay, this article is over. There will be other debugging records in the future!


Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.