Install the Chinese Input Method under jsunpack-N (3) Ubuntu in Jiangnan

Source: Internet
Author: User

Ubuntu 10.04 installation of Chinese Input Method:

Ps: the input method command is very simple:

1. Install scim intelligent Pinyin input method:

sudo apt-get install scim-pinyin im-switch

2. Set the Default Input Method to scim:

Im-switch-s scim (sudo is not available for normal users)
When error: update-alternatives: Cannot find alternative '/etc/X11/xinit/xinput. d/scim' occurs:

Set the Default Input Method to scim again:

SudoUpdate-alternatives -- install/Etc/X11/Xinit/Xinput. d/All_ALL
Xinput-all_ALL/Etc/X11/Xinit/Xinput. d/Scim30

SudoIm-switch-s scim

Remember to restart the system ~~

Some people say it still doesn't work?

Try this:

Because SCIM is just an input method platform, you also need to install the input method (or code table) on it ).

For example,

Apt-get install scim-chinese

Now you can use the intelligent Pinyin input method!

You must configure it before using it.

Configuration method: create a file named 95xinput in/etc/X11/xsession. d/. The file content is as follows:

Xmodifiers = "@ im = scim"
Export xmodifiers
Export gtk_im_module = scim

Save the file. After confirming that the content is correct, exit X (it is recommended to exit X and run the exit command to re-login once). Then, press Ctrl + space to call up scim when entering X!

========================================================== ======================================

Jsunpack was able to run yesterday, but an error was reported:Fatal: Failed to find pre. js and post. js

Check the source code of jsunpackn. py:

If not (OS. Path. exists (self. Options. PRE) and OS. Path. exists (self. Options. Post )):
Exit ("Fatal: failed to find pre. js and post. js ")

It turns out to be my post. js or pre. A Javascript file does not exist, and blue Blue finds its pre. js has, why didn't I have it? I updated svn again and found that my lovely anti-virus software has deleted it, closed it, And pre. put js in the jsunpack folder.

After the last problem is solved, an error is returned:Error: Fatal error in decodeJS: % s (probably you are missing "js" in your path)

When I checked the source code, I found that try-try t Exception. e had too many code and gave up. I had to study it. I felt that the js environment variable of SpiderMonkey was not included in the PATH, then google to modify the environment variable "

Modify the profile file:
# Vi/etc/profile
Add the following to the last line in the profile:
PATH = $ PATH:/home/ouyang/Desktop/jsunpack-n/depends/js-1.8.0-rc1-src/Linux_All_OPT.OBJ/



You can.

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.