Newifi Mini Pure version OpenWrt compatible kernel firmware, integrated rt2860v2, mt76x2e Drive

Source: Internet
Author: User
Tags svn

http://lxf.me/291

http://clz.me/rt2860v2-package/

Based on native OpenWrt Barrier breaker 14.07, the SDK && ImageBuilder is built to be compatible with the official 14.07 kernel to directly install any official source package (including kernel modules).

Trying to do this is mainly because the Pandorabox firmware does not pack some of the kernel modules I need because they are all 3.10 kernels and some KO can be forced to install by ignoring warnings, but a small number of KO due to reference kernel header file config is not binary compatible (for example, Ipset, you know).

Friendly Reminder 1: This firmware is not suitable for ordinary small white use, need to have a certain understanding of openwrt, with the primary Linux toss ability, at least to be able to use VIM to edit network, wireless and other profiles, because Luci does not support the configuration of rt2860v2-driven wireless parameters.
Friendly Reminder 2: This firmware is pure version, not because any user likes to integrate any function, require a variety of functions, please opkg installation.

Thanks to the leak-driven code of the relevant units as well as LINTEL, DQ and other great gods contribution: https://github.com/qdk0901/openwrt-mt7620

Known Issues:
1, unable to configure wireless via Luci. This is the original Ralink-driven mishap, please refer to the example configuration/etc/config/wireless below.
2, 5G drive using samba will be smoked, pandorabox also have this problem, see http://www.right.com.cn/forum/thread-149292-1-1.html#pid936103.

change history:

20141104 R2:
1, port to 14.07 official version (14.07-RC3 is not normal use of USB).
2, add 5G drive kmod-mt76x2e.
3. The wireless configuration script uses the latest Pandorabox script.
4, restore the default USB software package.
5, repair 2.4G and 5G of LED.

20141023 R1:
1, remove mac80211 and rt2800 related drive.
2. Add rt2860v2 driver, fix a error in reading ROM.
3, add Luci-i18n-chinese
4, remove the IPv6 related software packages and UCI initialization write IPv6 related configuration.
5, remove the USB-related software package (when the kernel is compatible with reload).
6, the revision of the Newifi mini switch interface definition.
7, the initial IP address for 192.168.99.1 (most people buy this when from routing)
8, the initial root password is admin.

/etc/config/wireless Example:

Config wifi-device ' ra0 ' option
	type ' rt2860v2 '
	option mode ' 9 '
	option Channel ' 6 '
	option txpower ' 100 ' C4/>option ht ' 20+40 '
	option Country ' US '
	option disabled ' 0 '

config wifi-iface
	option device ' RA0 '
	option Network ' LAN '
	option mode ' AP '
	option SSID ' Newifi '
	option encryption ' psk2 '
	option key ' xxxxxxxx '

config wifi-iface
	option device ' RA0 '
	option network ' wwan '
	option mode ' STA
	' Option SSID ' tplink '
	option encryption ' psk2 '
	option key ' xxxxxxxx '

config wifi-device  rai0
	Option type     mt7612
	option mode
	option Channel  auto
	option txpower
	option HT 20+40+80
	option country US
	
config wifi-iface
	option device   rai0
	option network	LAN
	option Mode     AP
	option SSID     newifi_5g
	option encryption psk2
	option key xxxxxxxx

Download Address: openwrt-newifi-y1-r2-20141104

==========================================================

Recently, a friend to a telecom enterprise-level AP, said let me play. Prior to doing five years of enterprise-level AP development, for AP or there is a bit of enthusiasm, whenever there is a chance to play some.

This AP is zn-7200-h500, the mirror is based on openwrt development. But the function is not rich enough, or do-it-yourself customized a practical AP bar.

To put it simply, compile the process:
1. Build a compilation environment
Install the VMware virtual machine on your Win7 Professional, virtual machine installation Ubuntu 14.04
Compilation will be used but not limited to the following components, libraries
GCC, g++, binutils, Patch, BZIP2, Flex, Bison, make, autoconf,
GetText, Texinfo, unzip, sharutils, Subversion, Libncurses5-dev,
Zlib1g-dev, Gawk, AsciiDoc, Libz-dev

sudo apt-get install X


2. Download OpenWrt source
The terminal enters the directory where it needs to store the project and performs the following actions
mkdir openwrt//Create a OpenWrt folder
CD openwrt//Enter OpenWrt folder
SVN co svn://svn.openwrt.org/openwrt/trunk//Download the source trunk version of the official website
CD Trunk
./scripts/feeds update-a//update package
./scripts/feeds install-a//installation packages

3. Compile the source code
Make Menuconfig//Enter the custom interface (which can select the chip model, integrated components, etc., according to the actual situation selected)

Make v=99 (Start compilation)
A few notes:
(1) Initial compilation, the host needs to network, because openwrt need to download source and library files and other components of the network. This process is very long, and OpenWrt official website download is not stable, occasionally there will be download failure. If you encounter a download failure, you can manually download the appropriate compressed file, and then put it in the trunk/dl/directory.

(2) speed up the compilation, if their computer performance is strong enough to open up several processes for compiling, as long as the compile time plus-JX (x is the individual according to their own computer strength, the number of their own definition, such as the author uses the-j8). Once added-JX, the error message may not be able to visually see the error message, this time need to recompile, plus v=99, do not add-JX. such as make v=99.

(3) Compile permission: OpenWrt is not recommended to compile under root permission, this will be checked at compile time, otherwise do not let compile. If you need to compile under root permissions, you need to add force=1.


4. Build the location of the image.
Compilation-generated mirrors are uniformly stored in the trunk/build_dir/target-mipsel_24kec+dsp_uclibc-0.9.33.2/linux-ramips_mt7620n/directory.

5. Custom OpenWrt for your own veneer type
The above 4 steps are only possible to compile the image of some of the router models that OpenWrt already supports, and what if their routers are not in the support list. Obviously, it is impossible for the openwrt to exhaust all the routers, and it is impossible to know your claim. So, you can only rely on yourself. This step still requires some knowledge accumulation and skills.
First of all, you need to have some hardware features of the current router, such as: Ethernet port is a few, which port is a network of ports, which are LAN port, whether the wireless interface needs to bridge the cable LAN, flash and the size of memory ...

What the. These little concepts are not, then or do not look down, and other users to share out to pick up the ready-made bar.

In./target/linux/ramips/image/makefile, we can add one of our router customization.
We first found
"# mt7620n Profiles"
According to gourd painting scoop, increase
image/build/profile/zdch500=$ (call buildfirmware/default16m/$ (1), $ (1), zdch500,zdch500)
Remember to add ZDCH500 at the same time, or not mirror
Ifeq ($ (subtarget), mt7620n)
Define Image/build/profile/default
$ (call image/build/profile/zdch500,$ (1))
Endef

Only by the above action is not enough, we also need to provide the corresponding DTS files.
./target/linux/ramips/dts/zdch500.dts
This file is used to describe hardware related information, such as GPIO, flash partitions, USB, etc.

6. End.

Need to know more about the Netizen, you can communicate in private.

========================================

rt2860v2 WiFi Drive for MT7620 openwrt package

Thanks to DQ, big tea garden ding two great God to provide guidance, the following package by DQ Packaging, configuration are lintel, thank lintel contribution.

Because of the two-bit help, we can now easily use the mt7620-openwrt.

Be thankful, spread and share, is the way of open source.

The github:https://github.com/qdk0901/openwrt-mt7620 of DQ

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: info-contact@alibabacloud.com and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.