Solved the problem of "failed to create mutex"

Source: Internet
Author: User

Original English text and post address:


I have got the same issue. It seems like Visual Studio 2005 and the web application pool running ASP. NET 2.0 are having a conflict over the Temporary Folder.
The workaround I have got for now is:
-If you have Visual Studio 2005 is open, close it
-Go tot the ASP. NET Temporary Folder for V2.0 of the framework
<Windows dir> \ microsoft. Net \ framework \ V2.0 <extra numbers> \ temporary ASPnet pages
-Remove the folder for your application (or all of them)
-Reset IIS (on a command line window,> iisreset) [not always needed, but I had to use it sometimes]
-First browse your page from IE (http: // localhost/your app)
-Then reopen Visual Studio

1. If vs2005 is still on, disable it.
2 to ASP. \ Microsoft. net \ framework \ V2.0 \ temporary ASPnet pages
3. Delete the directory of your project (or delete both directories)
4 restart IIS (if you enter iisreset in the command line)
5 open IE to access your project (http: // localhost/yourapp)
6 and then start vs2005

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.