Completely troubleshoot Ubuntu 10.04 on some of the sound card does not support or headphones silent problems

Source: Internet
Author: User
Tags bz2 lenovo

One of my friends ' notebooks installed the Ubuntu system on my recommendation. Originally he installed a version 9.10, WIFI support some problems. He then upgraded to version 10.04, Wi-Fi was normal, but there was no sound when the headset was plugged in and only the speaker was used.
In order to solve this problem, I began to study from 11 o'clock today, until the evening of 19 o'clock to be successfully done.

Symptom description
The Ubuntu 10.04 system, the Thinkpad x100e notebook, uses Conexant 80925 (looks like this number, if it doesn't matter, all Conexant chip solutions are the same) chip's sound card. The speakers continue to occur after the headphones are plugged in and the headphones are not audible.

Please note: If you are just trying to solve this problem, skip the previous attempt and read the final solution directly. However, reading these attempts, for beginners, can also increase a lot of insight.

Try one: Reinstall the operating system

Since this friend's laptop had no problem installing the 9.10 version, the first thing I thought was the possibility of a problem upgrading to 10.04. So I decided to reinstall the latest 10.04 operating system directly.
The problem is that his laptop does not have an optical drive, so I need to make a boot disk that installs Ubuntu 10.04.
First download Gets the ubuntu-10.04.iso image file.
Then, insert a useless CD (the capacity is preferably above 1GB), select "System"->"System Management"->"make boot Disk" in Ubuntu, click "format" format the disk (please back up in advance), then select the mirror that I downloaded to, make a launch U disk.
After the production, use the U Disk Boot system (in the x100e operation: Press Enter when the boot, then press F12, then select USB-HDD). When installing Ubuntu 10.04, be careful not to install two identical systems, but to overwrite the original system.
Result: Reinstall ended, the problem remains.

try two: Edit modprobe configuration

According to the information found on the Internet, you can edit the modprobe configuration file to solve the problem, but please note. In the Ubuntu high version, the file is appended with the. conf suffix. (Many people do not have the document because of this.) )
To solve the problem by editing the file, you need to be clear on a lot of things.

1, what is ALSA.
Linux manages the sound card driver through ALSA. It provides a more unified interface for a variety of sound cards. It is modular management, and the module at the beginning of snd-is such a module.

2, which module to manage your audio equipment.
Check your SND module with the following command. [Copy to Clipboard] View Code SHELL

Lsmod | grep ' ^snd-'

Identify the modules used by your sound card audio device in the results found. In my case, this module is Snd-hda-intel.

3, clear your sound card model. [Copy to Clipboard] View Code SHELL

sudo head-1/proc/asound/card0/codec#0

4, according to your sound card model, determine your sound card similar model.
[1] to the latest version of the ALSA Driver source code.
[2] finds the/alsa-kernel/documentation/hd-audio-models.txt file and opens it with a text editor.
[3] Browse for a sound card model similar to or identical to your sound card model, such as your sound card is ALC880, and then there are these lines nearby:

3stack 3-jack in/a headphone out
3stack-digout 3-jack in Back, a HP out and a SPDIF out
5stack 5-jack in Back, 2-jack in front
5stack-digout 5-jack, 2-jack in front, a SPDIF out
6stack 6-jack in Back, 2-jack in front
6stack-digout 6-jack with a SPDIF out
w810 3-jack
Z71V 3-jack (HP shared SPDIF)
Asus 3-jack (ASUS Mobo)
Asus-dig Asus with SPDIF out
Asus-dig2 Asus with SPDIF out (using GPIO2)
Uniwill 3-jack
Fujitsu Fujitsu Laptops (Pi1536)
F1734 2-jack
LG LG Laptop (M1 Express dual)
LG-LW LG lw20/lw25 Laptop
Tcl Tcl S700
Clevo Clevo Laptops (m520g, m665n)
Medion Medion Rim 2150
Test for testing/debugging purpose, almost all controls can
Adjusted. Appearing compiled with
$CONFIG _snd_debug=y
Auto Auto-config reading BIOS (default)

The left is its corresponding Model, the right side is the annotation. Remember, defaults are the default scenario.

5. Find the sound card parameters
In the source code you download, find Alsa-configuration.txt, from the chip model in the keyword, is generally the last paragraph of search, or lsmod get the sound card model name search, and then use the chip model positioning. Identify the available parameters.

6, edit the configuration file
Added to/etc/modprobe.d/modprobe.conf,/etc/modprobe.conf or/etc/modprobe.d/options, depending on the release, is the first in Ubuntu 10.04, The previous version is the second, and the other distributions may be very different.
Remember to open your text editor in sudo. On the last line (please do not quickly copy):? [Copy to Clipboard] View Code SHELL

Options Snd-hda-intel single_cmd=1 MODEL=LAPTOP-EAPD

Here, Snd-hda-intel to be changed to your SND module name (in the above there is a lookup method), single_cmd=1 to change to the sound card parameters (to a parameter combination test), model written on the corresponding model one.
Constantly modify the parameters and Model, if your luck is good enough, you should be able to solve this problem.
Each time you use sudo to edit the file, and then restart it, and then test your sound card again.
If you cannot start at reboot, try pressing Ctrl + ALT + F2, then go to the console and type sudo reboot reboot.
It is possible to solve this problem by trying it again and again. However, I have not been able to solve the problem.
If you don't want to reboot every time, you can try to kill the program that occupies your sound card and reload the sound card module.

try three: Compile and install the latest version of the ALSA driver

There are a lot of articles on the Internet that the previous ALSA driver does not support many sound card models and headphones, and upgrading to the latest version of the ALSA driver can solve the problem. The version of Ubuntu 10.04 is 1.0.22, and the latest version is 1.0.23, which requires upgrading the ALSA version to the latest.
First, download the latest version of Alsa Driver from Three packages are to be downloaded: alsa-driver,alsa-lib,alsa-utils. When the download is complete, it should be installed in the order that it was previously in.

1. Compile and install Alsa-driver.
[1] Decompression alsa-driver to ~/ad/.
[2] in the terminal input:? [Copy to Clipboard] View Code SHELL

Sudo/etc/init.d/alsa-utils stop
sudo/etc/init.d/alsasound stop
cd ~/ad/
sudo make install

[3] If the hint cannot find the libasound greater than 1.0.16 and cannot find an error such as the Xmlto command, please install the dependent package (below) before continuing. [Copy to Clipboard] View Code SHELL

sudo apt-get install build-essential
sudo apt-get install linux-headers-' uname-r '
sudo apt-get install Libncursesw5-dev
sudo apt-get install gettext
sudo apt-get install xmlto
sudo apt-get install Kernel-package gcc make Libc6 libc6-dev

Downloading these packages and compiling the installation success probably requires three hours time.

2. Compile and install Alsa-lib.
[1] Decompression alsa-lib to ~/al/.
[2] in the terminal input:? [Copy to Clipboard] View Code SHELL

CD ~/al/
sudo make install

3. Compile and install Alsa-utils.
[1] Decompression alsa-utils to ~/au/.
[2] in the terminal input:? [Copy to Clipboard] View Code SHELL

CD ~/au/
sudo make install

In the above "sudo./configure" compilation process, like I encountered the following error:
Checking form.h presence ... yes.
Checking for form.h ... yes
Checking for New_panel in-lpanelw ... no
You need to create the following links before you rerun the sudo./configure compile step:? [Copy to Clipboard] View Code SHELL

sudo ln-s
sudo ln-s
sudo ln-s libmen
sudo ln-s

4, configure your sound card.
[1] Enter the following command at the terminal:? [Copy to Clipboard] View Code SHELL

sudo alsaconf

Then the system will ask you some questions, mainly let you choose the sound card, the following questions are answered OK can be, the last choice No_more_cards exit.
[2] Enter the following command at the terminal:? [Copy to Clipboard] View Code SHELL

CD ~/au/alsamixer/
sudo chmod +x./alsamixer

Where ~/au is the path where you unzip the alsa-utils.
Then the system will appear some settings screen, where you can choose the sound card, automatic modification configuration, etc., may also give you the ability to adjust the volume, monitoring status and so on.

5. Restart your computer
Restart your computer and your sound card may be audible. (According to the survey, many sound cards can be solved by this method)

5, the implementation of "try two"
If the sound card still does not sound (for example, I ...) And you haven't tried two yet, please do "try two".
(Conclusion: Many people have been able to speak at this time, except mine.) )

try four: Use model not in the list

If your sound card model is not in the list of/alsa-kernel/documentation/hd-audio-models.txt files in the Alsa-driver source code, then you can take the following approach:
[1] test with adjacent models.
If your model is not supported, but similar models are available in this list, please use all models corresponding to this model to try to modify the Modprobe configuration. Modify the method with the try two.
[2] with a similar model test.
Some models do not have similar models available, but some of the model annotations remind you of certain types of laptops or desktops, and are tested decisively.
For example, model lenovo-x200 This model annotation is, suitable for the Lenovo X200 notebook.
[3] test with other model.
If it is unfortunate that neither, please use a random model for testing.
(I belong to the third party, and the tests are invalid)

try five: Use the ALSA driver provided by the community to support the chip

There is very little information on the Internet about this method. Through Google, I found a ALSA driver package that supports the Conexant chip set in the Ubuntu community abroad. Address:
Download the Deb package here and install it. Although this package is only 4MB, it takes a long time to install.
The problem is finally resolved when the computer restarts after the installation is complete.

I first played Ubuntu, read some books but the knowledge is still very shallow, write the wrong place please treatise, thank you
Last February, through a trial final decision to install Ubuntu 11.10 on the laptop, the laptop for f8va use ATI HD3650, through the online search guide installed complete its own drive. It used to be normal, but there was a problem that bothered me.
Problem Reason:
The horn plays sound normally, but does not have the sound to insert the earphone, but pulls the earphone slightly to pull out a little and has the sound, but does not have the left and right channel difference; I thought it was the headphones, but back to the XP system, everything's fine. After a tangle of half a month or find their own tutorial reload sound driver,
During this time I searched a lot of installation guide, recommend an article
This is the beginning of my nightmare when I download the latest version of Alsa Driver source code in the way it says, to
Because not familiar with Linux (in fact, even their own sound card model did not find out, careless a) in the selection of a sound card randomly, resulting in the system after the system can not find equipment, voice no
-----------------------------------------------------------------------------------------------Gorgeous Segmentation---------------------- ----------------------------------------
The so-called disease nasty disorderly Touyi, tried a lot of methods, also looked for a lot of information, during the basic to make their own sound card model figure out;
The cottage is not, then choose the Regular Army, go to drive home to find Realtek for Linux dirver
Http:// ... c883-alc8/
--> here I would like to say that the ALSA Dirver version 1.0.24 provided by Realtek is lower than that of the official ALSA, but I personally feel 1.0.24 is more suitable for ALC662
The reason: According to Bowen [2] Locate the/alsa-kernel/documentation/hd-audio-models.txt file and open it with a text editor.
[3] Browse for a sound card model similar to or identical to your sound card model, 1.0.25 inside is like this
Asus-mode1 Asus
Asus-mode2 Asus
Asus-mode3 Asus
Asus-mode6 Asus
Asus-mode7 Asus
Asus-mode8 Asus
What is this. It feels weird anyway.
The following is Realtek for Linux dirve 1.0.24 information
3stack-dig 3-stack (2-channel) with SPDIF
3stack-6ch 3-stack (6-channel)
3stack-6ch-dig 3-stack (6-channel) with SPDIF
6stack-dig 6-stack with SPDIF
lenovo-101e Lenovo Laptop
eeepc-p701 ASUS EeePC P701
ECS Ecs/foxconn Mobo
M51va ASUS M51va
G71V ASUS g71v
H13 ASUS H13
g50v ASUS g50v
Asus-mode1 Asus
Asus-mode2 Asus
Asus-mode3 Asus
Asus-mode6 Asus
Asus-mode7 Asus
Asus-mode8 Asus
Dell Dell with ALC272
DELL-ZM1 Dell ZM1 with ALC272
SAMSUNG-NC10 Samsung NC10 Mini Notebook
Auto Auto-config reading BIOS (default)
This is similar to the Bowen Description ALC880 sample
After finding the cause of the problem, the Lego began to compile, configure no problem, make always make mistakes and say "modversions.h" is not found
So Google this thing to find a forum Altman0habb an article, inspired me.
From the error message I found that there was no way to find what was in Linux within the include path. h file, I found the path under the found modversions.h really put in config inside, did a half a day originally is
The path does not match the compiler error, so decisively thought of using ln-s directly to the Config folder into the directory under the Linux folder.
After this, the direct root user is used to drive the 1.0.24 with the./install automatically install Dirver, I choose to install the 2 sound devices that pop up during the period.

Some new, after installing Ubuntu, the system does not sound, mostly because Ubuntu "Voice control driver: Alsa" does not correctly identify the computer's sound card. The solution to this problem, although a bit complicated, but there is worth trying, after all, no one wants in the world of Ubuntu, no sound of the day ~

Solution: Go to the official website of alsa, download 3 sound card driver Control program installation package separately, to install.

One. Sound card driver Control program: Alsa download

1. Download website:

Here, we want to download the latest version of the Alsa 3 installation packages. From the above page, you can see the words "Download a package"-"current version" on the right.

Note: Alsa drive is constantly updated, we have to do is to download the latest version from the Internet, the above page location, directly provide the latest version of the direct download. This tutorial, I am currently the latest: 1.0.20, as an example to explain. Maybe when you see this tutorial, the version has been updated (like 1.0.21,22,23). Go to the suit download on the line. The installation method, process, is also completely generic.

We need to download the following 3 installation packages:
(1) alsa-driver-1.0.20
(2) alsa-lib-1.0.20
(3) alsa-utils-1.0.20

Look at the picture, in this position, regardless of later version how to update, all directly click here on the line.

Description: 3443283390102202144.jpg

Photo: 3443283390102202144.jpg

Two. Installation

Download a good 3 packages, respectively:alsa-driver-1.0.20.tar.bz2 and alsa-lib-1.0.20.tar.bz2 and ALSA-UTILS-1.0.20.TAR.BZ2

These 3 packages, installation methods, installation procedures, installation procedures, exactly the same, are all Linux systems, the most original: "3 steps to compile and install". Therefore, my tutorial to the first package: alsa-driver-1.0.20.tar.bz2, to tell the specific installation practice process, the back of their own suit can be. In particular, these 3 packages are installed in sequential order, according to: Driver--lib--utils. All right, let's get started.

1. First in the terminal, download: Xmlto, this package and install

Method: From "Application"-"attachment", open "terminal", enter: sudo apt-get install Xmlto. This will download the installation. When installed, put the terminal window aside and we'll use it later.

Description: 4005388918593367074.jpg

Photo: 4005388918593367074.jpg

2. Find you download good:alsa-driver-1.0.20.tar.bz2, double-click to open it, we can see inside a folder, with the left mouse button, drag to the "desktop." Wait a moment, you will see on the desktop there are:alsa-driver-1.0.20, the name of the folder.

Description: 3110861442606787959.jpg

Photo: 3110861442606787959.jpg

4. Return to enter: ./configure Carriage return

3. In the terminal, we enter: CD desktop/ just the name of the folder , should be:CD desktop/alsa-driver-1.0.20(after you install LIB package, think about what it is here).

Description: 4859383997933303257.jpg

Photo: 4859383997933303257.jpg

Description: This step is legendary, compile, configure the source code, depending on the operating system, according to the software packages that come with it, so the configure process is different. Therefore, no one can predict what will happen. But there is a prerequisite, that is, you press ENTER, the screen will start rolling, until completed, you want to see if there is: Error, the word. If not, you can continue to the following steps, if the halfway appeared "error", it must be based on the end of the error prompted information, to search the Internet to resolve this error. Once resolved, return to the "./configure" again.

ALSA sound card Driver "Configure", generally do not encounter any errors, in the "Ubuntu Linux 9.04 Desktop" under the test can be passed. Look at the picture, finally appear: Hacking autoconf.h..., even if finished.

Description: 4263782947213752198.jpg

Photo: 4263782947213752198.jpg

5. When you are done, go back to the prompt and you can continue typing: make, and proceed to the next step. Enter, the screen continues to start scrolling, the same reason, to observe if there is no "error" appears

Description: 4263782947213752206.jpg

Photo: 4263782947213752206.jpg

In this process, there will be a "warning (warnning): Warning: The format string is not a literal string and there is no actual argument to be formatted," This is OK, ignore it. Look at the picture. Make the process is relatively long, about 20 minutes, and finally will appear inside the diagram: "ALSA modules were successfully compiled", on behalf of success.

Description: 39812589445479811830.jpg

Photo: 39812589445479811830.jpg

6. Return to command prompt after completion, input: sudo make install, enter can start installation drive.

Description: 39812589445479811830.jpg

Photo: 39812589445479811830.jpg

Because my system is already installed, this section does not have a screenshot. If there is no obvious "error" in the first two steps, then the last one, more than 80%, will not have any more problems.

Three. Installation of the following two packages.

Just now said, 3 packages, the steps to install, the process, exactly the same. I'm going to sketch it out.

1. For: alsa-lib-1.0.20

Double click on the downloaded package, unzip the folder inside to the desktop, and then inside the terminal:

CD Desktop/alsa-lib-1.0.20
(note that 2 steps above, there is no error, should be no, warning or whatever, do not need to tube it)
sudo make install

is finally completed. In fact, the first driver, is 3 packages inside the most important, it succeeded, and the back of the 2 almost will not have any problems.

2. For alsa-utils-1.0.20
Double click on the downloaded package, unzip the folder inside to the desktop, and then inside the terminal:

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.