Through understanding the PPP protocol, we found that PPP identity authentication is a very important part. The authentication process is divided into different stages. Let's take a look at the specific content here. First look at the topology used:
PAP two-way Identity Authentication
The R1 configuration is as follows:
- config t
- hostname R1
- username R1 password komy
- interface s0/0/0
- ip address 192.168.1.2 255.255.255.252
- encapsulation ppp
- ppp authentication pap
- ppp pap sent-username R2 password komy
- no shutdown
R2 is configured as follows:
- config t
- hostname R2
- username R2 password komy
- int s0/0/0
- clock rate 4000000
- ip address 192.168.1.1 255.255.255.252
- encapsulation ppp
- ppp authentication pap
- ppp pap sent-username R1 password komy
- no shutdown
PAP one-way Identity Authentication
R1 is configured as the authenticated party ):
- config t
- hostname R1
- interface s0/0/0
- ip address 192.168.1.2 255.255.255.252
- encapsulation ppp
- ppp pap sent-username R2 password komy
- no shutdown
R2 is configured as follows (primary authenticated party ):
- config t
- hostname R2
- username R2 password komy
- int s0/0/0
- clock rate 4000000
- ip address 192.168.1.1 255.255.255.252
- encapsulation ppp
- ppp authentication pap
- no shutdown
CHAP mutual identity authentication
- config t
- hostname R1
- username R2 password komy
- int s0/0/0
- ip address 192.168.1.2 255.255.255.252
- encapsulation ppp
- ppp authentication chap
- no shutdown
R2:
- config t
- hostname R2
- username R1 password komy
- int s0/0/0
- clock rate 4000000
- ip address 192.168.1.1 255.255.255.252
- encapsulation ppp
- ppp authentication chap
- no shutdown
CHAP one-way Identity Authentication
R1 (CHAP authenticated party ):
- config t
- hostname R1
- username R2 password komy
- int s0/0/0
- ip address 192.168.1.2 255.255.255.252
- encapsulation ppp
- no shutdown
R2 (CHAP primary authenticated party ):
- config t
- hostname R2
- username R1 password komy
- int s0/0/0
- clock rate 4000000
- ip address 192.168.1.1 255.255.255.252
- encapsulation ppp
- ppp authentication chap
- no shutdown
From: http://hi.baidu.com/51cmdshell