Install ruby-Debug

Source: Internet
Author: User

To install the ROR Debugger in netbeans, click "Debug main project" to install the ruby quick debugger. As a result, the installation fails... (In fact, it is installed using the gem install ruby-debug-y command.) I searched the internet and said that the other two gems must be installed before installation.

The following is a reference to the late brother's article

Bytes --------------------------------------------------------------------------------------------------------------------

Download ruby-debug-base for Installation
Ruby-debug-base (mswin32 version ):

Gem install ruby-debug-base-0.9.2-mswin32.gem

Then download the ruby-debug-ide Installation
: Ruby-debug-ide-0.1.3.gem
I tried only ruby-debug-ide-0.1.2.gem and ruby-debug-ide-0.1.3.gem in windows.

Gem install ruby-debug-ide-0.1.3.gem

Finally, install ruby-Debug.

Gem install ruby-debug-0.9.2.gem

Bytes --------------------------------------------------------------------------------------------------------------------

Follow the steps above to install it successfully. I tried to debugger it in scite, but it still does not work in netbeans.

In the past, I always held the guiding principle that "the latest version of GEM must be more perfect than the previous version, download the "latest" version of the three files, but there are always errors.

1.Initially, Cl is not an internal or external command:

Explanation:Cl is a compilation command for C ++, not for windows. That is to say, if you want to run this command at a Windows command prompt, you need to install visual c ++ 6.0,of course gccwith cl.exe.

Install a VC ++ and set the path of the CL command in the environment variable.

After vc6.0 is installed, I add the directory of cl.exe to the environment variable of the system.

2.Then, we always reported that the winsock2.h header file could not be found:

I found this file under vc98 and put it in the C:/Ruby/lib/Ruby/1.8/i386-mswin32/Win32/win32.h folder, because winsock2.h is called by the win32.h file, however, an error is reported. It is still not possible to add inlucde of vc98 to the environment variable. Then I have been entangled in this problem for a long time, so I do not know how to solve it.

3.I noticed that a fatal error u1077 error was reported, and cl.exe was executed in the command line. The prompt box mspdb80.dll could not be found, so I continued the online search

Explanation:The four files, namely, VC/bin/, msobj80.dll, mspdb80.dll, mspdbcore.dll, and mspdbsrv.exe, can be directly copied from common7/IDE/to VC/bin.

"Register environment variable" is not hooked during VC Installation"

Compile time:

(1) The mspdb60.dll cannot be found. The error code u1077: CL 0xc0000135 is displayed.

The environment variables are as follows:


VC installation path/bin; VC installation path/msdev98/bin

(2) the header file cannot be found, and the error u1077: CL 0x2 is displayed.

Determine Environment Variables


VC installation path/include

(3) The Library file cannot be found. The error message is displayed: u1077: CL 0x49d.

Determine Environment Variables


VC installation path/lib

4.Start netbeans6.1 again to automatically install the ruby quick debugger. It succeeded. However, when debugging the project, the error "cannot connect to the Web server -- http: // localhost: 3000/" cannot be displayed, what's even more embarrassing is that

At the beginning the default is 15 seconds, In the netbeans configuration file plus-J-Dorg.netbeans.modules.ruby.debugger.timeout = 50 to 50 seconds after the same error is reported.

I checked the Internet and said that one is to keep the timeout a little longer, and the other is to check that all the machines are correctly connected to, otherwise I will email them orz

5.Unload vc6.0 prepared to reinstall, installed vc2005, found an article ( said Ruby binary is compiled under vc6.0, in order to avoid various problems, or uninstall vc2005 and reinstall vc6.0 = _ =, and then remember to check "register environment variable ".

6.After vc6.0 is installed, Gem install ruby-debug-y can run successfully.

Cl.exe is also normal...

7.However, netbeans6.1 still had the timeout error. netbeans6.7 was able to debug the code. Finally, it was okay, and I was burst into tears.

8.Installed ruby-Debug gems




These are installed according to the guidance of Brother Ye Ming.




These are installed by netbeans6.1.


This is installed by netbeans6.7.


Ruby gems

Someone's installation tips

Ruby debugger overview

Related Article

Contact Us

The content source of this page is from Internet, which doesn't represent Alibaba Cloud's opinion; products and services mentioned on that page don't have any relationship with Alibaba Cloud. If the content of the page makes you feel confusing, please write us an email, we will handle the problem within 5 days after receiving your email.

If you find any instances of plagiarism from the community, please send an email to: and provide relevant evidence. A staff member will contact you within 5 working days.

A Free Trial That Lets You Build Big!

Start building with 50+ products and up to 12 months usage for Elastic Compute Service

  • Sales Support

    1 on 1 presale consultation

  • After-Sales Support

    24/7 Technical Support 6 Free Tickets per Quarter Faster Response

  • Alibaba Cloud offers highly flexible support services tailored to meet your exact needs.