1.
Tunnel interface is a virtual interface of the system, which is used to realize standard point-to-point transmission, and must be configured at both ends.
2. Tunnel refers to the communication between one protocol and another. IPv6 over IPv4 tunneling mechanism encapsulates IPv4 in front of IPv6 packets
Through the
tunnel, IPv6 packets can cross the IPv4 network to realize the interworking of isolated IPv6 network. Before IPv6 is fully implemented, there are always some
The network provides IPv6 support first, but these IPv6 networks are isolated by the backbone network running IPv4 protocol. Tunnels are used to connect these isolations
IPv6 network is the most easy technology to adopt in the early stage of the transition from IPv4 to IPv6.
Command:
R2 (config) × int tunnel0 / / configure the tunnel interface
R2 (config if) ා IPv6 add 2010:2323:: 2 / 64 / / configure the address of the tunnel interface
R2 (config if) × tunnel source S0 / 1 / / configure the source address of the tunnel
R2 (config if) ා tunnel destination 23.23.23.3 / / configure the destination address of the tunnel
R2 (config if) ා tunnel mode IPv6 IP / / configure the tunnel mode. The default is gre
R2 (config) ාipv6 route:: / 0 tunnel0 / / configure static default route
IPv6 < wbr > tunnel configuration
R1(config)#ipv6 unicast-routing
R1(config)#ipv6 router rip cisco
R1(config-rtr)#split-horizon
R1(config-rtr)#poison-reverse
R1(config)#int lo0
R1(config-if)#ipv6 add 2011:1111::1/64
R1(config-if)#ipv6 rip cisco enable
R1(config)#int s0/0
R1(config-if)#ipv6 add 2009:1212::1/64
R1(config-if)#ipv6 rip cisco enable
R1(config-if)#no sh
R2(config)#ipv6 unicast-routing
R2(config)#ipv6 router rip cisco
R2(config-rtr)#split-horizon
R2(config-rtr)#poison-reverse
R2(config)#int s0/0
R2(config-if)#ipv6 add 2009:1212::2/64
R2(config-if)#ipv6 rip cisco enable
R2(config-if)#ipv6 rip cisco default-information originate
R2(config-if)#clock rate 128000
R2(config-if)#no sh
R2(config)#int s0/1
R2(config-if)#ip add 23.23.23.2 255.255.255.0
R2(config-if)#no sh
R2(config)#int tunnel0
R2(config-if)#ipv6 add 2010:2323::2/64
R2(config-if)#tunnel source s0/1
R2(config-if)#tunnel destination 23.23.23.3
R2(config-if)#tunnel mode ipv6ip
R2(config)#ipv6 route ::/0 tunnel0
R3(config)#ipv6 unicast-routing
R3(config)#ipv6 router rip cisco
R3(config-rtr)#split-horizon
R3(config-rtr)#poison-reverse
R3(config)#int s0/0
R3(config-if)#ipv6 add 2009:3434::3/64
R3(config-if)#ipv6 rip cisco enable
R3(config-if)#ipv6 rip cisco default-information originate
R3(config-if)#clock rate 128000
R3(config-if)#no sh
R3(config)#int s0/1
R3(config-if)#ip add 23.23.23.3 255.255.255.0
R3(config-if)#clock rate 128000
R3(config-if)#no sh
R3(config)#int tunnel0
R3(config-if)#ipv6 add 2010:2323::3/64
R3(config-if)#tunnel source s0/1
R3(config-if)#tunnel destination 23.23.23.2
R3(config-if)#tunnel mode ipv6ip
R3(config)#ipv6 route ::/0 tunnel0
R4(config)#ipv6 unicast-routing
R4(config)#ipv6 router rip cisco
R4(config-rtr)#split-horizon
R4(config-rtr)#poison-reverse
R4(config)#int lo0
R4(config-if)#ipv6 add 2014:4444::4/64
R4(config-if)#ipv6 rip cisco enable
R4(config)#int s0/0
R4(config-if)#ipv6 add 2009:3434::4/64
R4(config-if)#ipv6 rip cisco enable
R4(config-if)#no sh
Experiment debugging
R1#ping ipv6 2014:4444::4 source lo0
IPv6 < wbr > tunnel configuration
Note: if IPv6 Routing is enabled on the switch, the following configuration should be done first:
SW1(config)#sdm prefer dual-ipv4-and-ipv6 routing
SW1 can only support IPv4 and IPv6 Routing functions after it is restarted
SW1 (config) × IPv6 unicast routing / / enable IPv6 Routing